Who the fuck invented Hungarian notation?

lpszName, bVisible, pNext, ppData...

A variable's type should already be clear by its name and scope. If not, get yourself some decent IDE that helps you out. Why this style is still in use in code like the Vulkan API is beyond me... IT IS NOT USEFUL!

  • 2
    We did obviously
  • 1
    I support adding a "p" to the variable name.. However others are really redundant, if the function is short enough one can look 15 lines above and see the type.
  • 2
    To be fair, I don't think it was invented for modern languages or modern IDEs in mind.
Add Comment