2
Katakompe
289d

Fucking hell of a Spring Boot 3 upgrade. Half the libraries aren't ready for the upgrade, nothing is document, the migration guides are trash and our internal supporting libraries are riddled with bugs.
Why did I get that godforsaken task?

Comments
  • 0
    :-)

    There is always a loser....

    (Yeah that applies to me, too)
  • 1
    Most of the functionalities of the libraries you need are either built into JDK17 or the Spring Boot 3 framework itself. You don't need shits like Apache Commons or anything else for the simple tasks like you used to. But I agree, the documentation is shit and figuring out alternatives are painfully time consuming.
Add Comment