14
rantsauce
89d

Okay, here's a rant for you: neo fucking vim and their fucking wrapper plugins for wrapper plugins for wrapper plugins for plugins "tHat'S wRitTen in LOWAA". The fuck is wrong with you, you fucking dumpshits?! Bram was right to not get involved in this bullshit!!

Comments
  • 4
    I might get shit for this but

    I feel (neo)vim is a horrible tool for developing software and the people who preach it like it's the second coming of Christ are even more annoying than the "install linux" crowd
  • 2
    @LotsOfCaffeine Exactly!

    Install Linux though
  • 1
    @LotsOfCaffeine agree. People are just forcing a tool for whole edit/decelop/build/debug. Just use keybinds in VS Code.
  • 1
    vi is good enough, no need for fancy shit.
  • 1
    @thebiochemic punchcards, baby.
  • 6
    I like neovim. The Lua API is much nicer to use than viml. The problem is the plugin developers. A lot of them have the same values as JS developers: iterate fast, make breaking changes even faster, reinvent the wheel every other week, it's ok if things break downstream cause the user should've rtfm. Luckily there's already some pushback against it, so hopefully it'll calm down soon
  • 0
    @killermenpl You could not have said it better!
  • 1
    I'm just astounded at how they managed to produce so many bugs that look so much like duplicate state in such a simple, _modal_ editor. I tried astronvim but every hour or so I needed to tap ESC four times to reestablish consensus to the extent that I could type :q without some plugin hijacking the keys and then relaunch the editor.
Add Comment